Investigating Network Delays/Errors
Resolved
Sep 1, 2026 at 7:13pm UTC
We have confirmed that network latencies have returned to normal, and Google has now concluded restoration of networking capacity in the affected region and are considering their related incident closed.
As such, we're closing this incident but will continue to monitor and also look for opportunities to minimize future impacts from similar external events.
If you continue to experience any issues, please contact the Avid helpdesk at help@avidai.com.
Affected services
Updated
Sep 1, 2026 at 6:46pm UTC
We're continuing to monitor, and have seen latencies return to near-normal levels since around 1:17pm Central Time. Google continues their work to fully restore networking capacity in the affected region, and we will continue to monitor confirm the effectiveness of those fixes.
During the peak impact window (1:06–1:20pm Central Time), we found that less than 0.1% of requests were affected (slowness to errors). Due to the limited impact, we're classifying this as a minor service degradation.
If you continue to see abnormal slowness or receive a Service Unavailable error, please feel free to contact help@avidai.com
Affected services
Created
Sep 1, 2026 at 6:06pm UTC
We're currently seeing slow service response due to a networking issue within Google Cloud Platform. While the Avid application remains operational, these networking issues may lead to slow page loads of the Avid application, as well as occasional timeout errors.
While the Google issue began earlier, we first observed its impact on Avid around 1:06pm US Central Time.
We're monitoring the issue and tracking Google's incident response issue and will provide updates as needed.
Affected services